Latest News

Joomla 1.5 is no longer secure

Joomla 1.5 has reached the end of it's life and is no longer supported. This means that any security flaws that are found will no longer be fixed and will leave the site wide open to hackers.

Read More
Video

How easy is WordPress?

Just listen to Dawud Miracle’s intro below: